IM s.c. A.Bielicki, C.Ścisiński www.archimedic.pl

Pakiet programów do przesyłania, archiwizacji i oglądania obrazów medycznych

ARCHIMEDIC

Komponent

RSR2

Stacja Przeglądania obrazów

wersja 2009

INSTRUKCJA OBSŁUGI

IM s.c. A.Bielicki, C.Ścisiński

www.archimedic.pl

Truskaw, Maj 2009

Spis treści

1 WSTĘP 5

2 OPIS OGÓLNY PROGRAMU 5

2.1 Przeznaczenie programu RSR2 5

2.2 RSR2 w szpitalnej sieci PACS 5

2.3 Źródła oglądanych obrazów 5

3 OBSŁUGA PROGRAMU RSR2 5

3.1 Uruchamianie programu 6

3.2 Używanie elementów menu 7

3.3 Otwieranie badań 9

3.3.1 Odbieranie obrazów wysłanych z urządzeń zewnętrznych 10

3.3.2 Pobieranie obrazów z archiwum podręcznego (lokalnego) 10

3.3.3 Pobieranie obrazów z archiwum sieciowego (PACS) 11

3.3.4 Pobieranie obrazów ze wskazanego katalogu 12

3.3.5 Pobieranie obrazów z płyty CD/DVD z badaniem pacjenta 12

3.3.6 Import obrazów do archiwum podręcznego 12

3.3.7 Otwieranie obrazów metodą “przeciągnij i upuść” 12

3.4 Operacje na seriach 13

3.4.1 Bezpośrednie przewijanie obrazów serii 13

3.4.2 Synchronizacja serii 13

3.4.3 Przewijanie serii przy użyciu kursora 3D 13

3.5 Operacje na obrazach 14

3.5.1 Wywoływanie narzędzi 14

3.5.2 Ustawianie kontrastu 14

3.5.3 Ustawianie powiększenia 15

3.5.4 Przesuwanie obrazu 15

3.5.5 Inwersja kontrastu („negatyw”) 15

3.5.6 Obracanie obrazu 16

3.5.7 Obsługa obrazów ruchomych 16

3.5.8 Kursor 3D 16

3.5.9 Wyświetlenie w skali 1:1 17

3.5.10 Lupa 17

3.5.11 DSA 17

3.6 POMIARY 17

3.6.1 Zasady używania narzędzi pomiarowych 17

3.6.2 Pomiar odległości 18

3.6.3 Kalibracja pomiaru odległości 18

3.6.4 Pomiar kąta 19

3.6.5 Pomiar obszaru zaznaczonego okręgiem 19

3.6.6 Pomiar obszaru zaznaczonego krzywą Beziera 19

3.7 NAGRYWANIE BADAŃ NA PŁYTY CD/DVD 20

3.8 USUWANIE BADAŃ Z ARCHIWUM PODRĘCZNEGO 21

3.9 WYSYŁANIE BADAŃ DO SERWERÓW PACS 21

3.10 NARZĘDZIA DODATKOWE 22

3.10.1 Przeglądarka tagów 22

4 KONFIGUROWANIE PROGRAMU 23

4.1 Konfigurowanie serwisowe 23

4.1.1 Struktura katalogów 23

4.1.2 Konfigurowanie współpracy z siecią PACS 24

4.2 Konfigurowanie adnotacji na obrazach 25

4.3 Konfigurowanie innych urządzeń w sieci PACS 26

4.4 Konfigurowanie Windows 26

4.4.1 Nagrywanie badań na płyty CD/DVD przez „zwykłego” użytkownika 26

5 WYMAGANIA SPRZĘTOWE 27

6 SERWIS I POSTĘPOWANIE W SYTUACJACH AWARYJNYCH 27

1 WSTĘP

RSR2 jest programem pakietu ARCHIMEDIC przeznaczonego do obsługi pracowni radiologicznych w zakresie przesyłania, przechowywania i udostępniania obrazów radiologicznych. RSR2 jest przeglądarką obrazów medycznych, w szczególności obrazów powstających w urządzeniach diagnostycznych takich, jak tomograf komputerowy, tomograf rezonansu magnetycznego, cyfrowe aparaty radiologii klasycznej, ultrasonografy, urządzenia do badań naczyniowych, itp.

Program operuje na obrazach przesyłanych w standardzie DICOM.

Program przeznaczony jest do przeglądania obrazów, nie jest przeznaczony do ich oceny diagnostycznej.

Program RSR2 stanowi jedynie narzędzie pomocnicze, służące do oglądania rezultatu badań diagnostycznych.

2 OPIS OGÓLNY PROGRAMU

2.1 Przeznaczenie programu RSR2

Program RSR2 przeznaczony jest do przeglądania obrazów diagnostycznych na oddziałach szpitalnych, w przychodniach, w gabinetach lekarskich, a także do omawiania przypadków podczas „kominków” lekarskich.

2.2 RSR2 w szpitalnej sieci PACS

Program RSR2 wraz z komputerem, na którym został zainstalowany może stanowić element sieci PACS. Obrazy mogą być do niego wysyłane z urządzeń medycznych siecią komputerową protokołem DICOM.

2.3 Źródła oglądanych obrazów

Obrazy oglądane programem RSR2 mogą być dostarczane ze szpitalnej sieci PACS lub odczytywane z nośnika zewnętrznego, takiego, jak płyta CD/DVD, pamięć USB, udostepniony dysk sieciowy, itp.

W większości przypadków obrazy przechowywane są w archiwum podręcznym i stamtąd otwierane. Przechowywanie w archiwum podręcznym oznacza, że obrazy zapisane są na lokalnym dysku, a ich położenie wpisane jest do bazy danych programu RSR2 w celu ich łatwego znajdywania.

Obrazy (badania) znajdujące się w archiwum podręcznym można nagrać na płyty CD/DVD.

Ponieważ dysk komputera ma ograniczona pojemność, badania starsze należy usuwać. Usunięcie badania z archiwum podręcznego oznacza usunięcie plików obrazowych oraz odpowiednich wpisów w bazie danych.

3 OBSŁUGA PROGRAMU RSR2

3.1 Uruchamianie programu

Program uruchamia się tak, jak większość aplikacji Windows, na przykład poprzez dwukrotne kliknięcie ikony skrótu (znajdującej się na pulpicie) lub ikony aplikacji.

Po uruchomieniu aplikacji otwiera się jej okno:

W części górnej znajduje się menu (panel menu, zawierający przyciski szybkiego dostępu).

Lewa strona okna (panel badań) przeznaczona jest do wyświetlania listy badań gotowych do otwarcia.

Obrazy wyświetlane są w głównej części okna (panel obrazów).

Zaleca się, aby aplikacja pracowała w trybie okna maksymalizowanego (tzn. Zajmującego cały obszar monitora).

3.2 Używanie elementów menu

  • Plik – służy do pobierania badań do otwarcia. Sposoby otwierania badań są omówione w p.3.3.

  • Narzędzia – w obecnej wersji zawiera przeglądarkę tagów dicom wskazanego obrazu (omówiona w p.3.10.)

  • Konfiguracja – umożliwia konfigurowanie RSR2. Opcja omówiona jest w p.4.

  • Pomoc – zawiera informacje o programie i procedurę przedłużania licencji.

    Kosz – usuwanie obrazów I badan z obszaru RSR2.

Reset – przywrócenie początkowych ustawień przy których wyświetlany jest obraz

    Archiwum – pobieranie badań z archiwum lokalnego lub sieciowego (za pomocą Dicom Query/Retrieve).

Bufor nagrywania – otwarcie bufora nagrywania.

Pobieranie badań z Płyty CD zawierającej badanie pacjenta w standardzie Dicom, w szczególności zawierającej m.in. plik DICOMDIR.

Włączanie/wyłączanie wyświetlania linii referencyjnych pokazujących wzajemne położenie przekrojów.

Włączanie/wyłączanie wyświetlania pomiarów, tzn. linii pomiarowych, obszarów i podpisów.

Włączanie/wyłączanie wyświetlania opisów obrazów (np. data i typ badania, numer przekroju, itp.)

Synchronizacja automatyczna przeglądania serii w obrębie jednego badania (study).

Synchronizacja ręczna (manualna) serii z różnych badań (study).

Funkcja jeszcze niezaimplementowana. Rekonstrukcja MPR.

3.3 Otwieranie badań

Badania gotowe do przeglądania pojawiają się na liście w panelu badań RSR2:

Lista zawiera poszczególne badania; po podwójnym kliknięciu na badanie rozwija się lista serii tego badania. Kliknięcie na serię otwiera jej obrazy w panelu obrazów. Kliknięcie na otwartą serię powoduje jej usunięcie z panelu obrazów.

Pobieranie badań do panelu badań opisane jest w p.p. 3.3.1 do 3.3.5.

3.3.1 Odbieranie obrazów wysłanych z urządzeń zewnętrznych

Aplikacja RSR2 może samodzielnie odbierać obrazy wysyłane z sieci PACS w trybie Dicom Store. Umożliwia to wysyłanie badań z sieci PACS bezpośrednio do aplikacji RSR2 oraz pobieranie badań z sieci PACS poprzez mechanizm Dicom Query/Retrieve (z użyciem wyszukiwarki – opis w p. 3.3.3). Obrazy wysłane z urządzeń zewnętrznych zapisywane są w lokalnym archiwum.

3.3.2 Pobieranie obrazów z archiwum podręcznego (lokalnego)

Kliknięcie przycisku lub wybranie z menu opcji Plik->ARCHIWUM otwiera wyszukiwarkę badań znajdujących się w archiwum podręcznym. Jest ona pokazana poniżej:

Wyszukiwarka otwiera się domyslnie w trybie przeszukującym archiwum lokalne – pole „Query/Retrieve” jest niezaznaczone.

Domyślnie zaznaczone jest szybkie wyszukiwanie po nazwisku i imieniu oraz identyfikatorze pacjenta; oznacza to, że odbywa się ono od razu podczas wypełniania jednego z tych pól i lista wyświetlonych badań zawęża się. Tak więc nie jest konieczne wpisanie całego nazwiska (np. „Brzenczyszczykiewicz”), bowiem już po wpisaniu pierwszych kilku liter (np. „Brze”) na liście pozostanie kilka nazwisk rozpoczynających się od tych liter.

Bardziej złożone wyszukiwanie, z użyciem np. daty badania (możliwe szybkie wybieranie „Dzisiaj” lub „Wczoraj”), daty urodzenia, typu urządzenia, itd. wymaga ustawienia wybranego parametru i naciśnięcia przycisku „Szukaj w lokalnym archiwum”.

Aby otworzyć badanie należy je podświetlić na liście (całe badanie lub tylko niektóre jego serie) i kliknąć przycisk „Odczytaj zaznaczone”. Można jednocześnie otworzyć kilka badań.

3.3.3 Pobieranie obrazów z archiwum sieciowego (PACS)

Kliknięcie przycisku lub wybranie z menu opcji Plik->ARCHIWUM otwiera wyszukiwarkę badań znajdujących się w archiwum podręcznym. Zaznaczenie pola „Query/Retrieve” przełącza ją na wyszukiwanie z serwerów sieci obrazowej PACS:

Wyszukiwanie dotyczy badań udostępnionych przez serwer PACS (konfigurowanie omówione jest w dalszej części instrukcji) wybrany z listy w okienku pod polem wyboru Query/Retrieve. Należy zwrócić uwagę, że uruchomienie wyszukiwania bez określenia parametrów (np. zakresu daty, nazwiska, itp.) może trwac bardzo długo, a nawet zablokować komputer (na serwerze może być wiele tysięcy badań). Po znalezieniu szukanego badania należy je podświetlić (jedno lub kilka badań lub też wybrane serie jednego badania) i pobrać klikając odpowiedni przycisk w lewej części okna wyszukiwarki.

3.3.4 Pobieranie obrazów ze wskazanego katalogu

Wybranie z menu opcji Plik->Otwórz z dysku otwiera typowe w systemie Windows okno „Przeglądanie w poszukiwaniu folderu”. W oknie tym należy wskazać folder zawierający szukane obrazy.

3.3.5 Pobieranie obrazów z płyty CD/DVD z badaniem pacjenta

Płyty zawierające badania pacjenta nagrywane w standardzie Dicom powinny zawierać przeglądarkę umożliwiającą obejrzenie nagranych obrazów. Badania te można także obejrzeć aplikacją RSR2. W tym celu po włożeniu płyty pacjenta należy kliknąć przycisk z ikoną płyty CD. Badanie (jedno lub kilka) nagrane na płycie powinno pojawić się w panelu badań.

W przypadku dużej ilości nagranych obrazów pobieranie badania może potrwać dłuższą chwilę.

W przypadku problemów należy w pierwszej kolejności upewnić się, czy w katalogu głównym płyty CD/DVD znajduje się plik o nazwie „DICOMDIR”. Jeżeli takiego pliku nie ma oznacza to, że płyta nie jest zgodna ze standardem Dicom, a pobranie badania w opisywanym trybie nie jest możliwe.

3.3.6 Import obrazów do archiwum podręcznego

Wybranie z menu opcji Plik->Importuj z dysku otwiera typowe w systemie Windows okno „Otwieranie”. W oknie tym należy wskazać plik obrazu, który chcemy otworzyć. Można wskazać plik DICOMDIR lub plik zawierający obraz dicom (np. z rozszerzeniem .dcm lub innym). Wskazane pliki zostaną zapisane w archiwum podręcznym.

3.3.7 Otwieranie obrazów metodą “przeciągnij i upuść”

Obrazy mogą być także otwierane poprzez “przeciągnięcie I upuszczenie” pliku obrazowego (np.DCM) lub pliku DICOMDIR do okna aplikacji RSR2.

W przypadku plików obrazowych w panelu badań pojawia się jeden obraz; w przypadku pliku DICOMDIR w panelu badań pojawiają się wszystkie zapisane w nim obrazy.

Opisana metoda jest mniej efektywna od metody importu (p.3.3.6), należy ją stosować tylko wtedy, gdy nie chcemy umieszczać oglądanych plików w archiwum podręcznym.

3.4 Operacje na seriach

Po kliknieciu miniaturki serii w panelu badań seria ta otwiera się w nowej ramce w panelu obrazowym. Poszczególne obrazy danej serii umieszczone są kolejno, “jeden pod drugim”.

Dostępnych jest kilka sposobów aby obejrzeć kolejne obrazy serii.

3.4.1 Bezpośrednie przewijanie obrazów serii

Przeglądanie kolejnych obrazów wybranej serii można przeprowadzić na kilka sposobów:

  • obracając kółkiem (środkowym przyciskiem) myszy

  • naciskając środkowy przycisk myszy i przesuwając mysz góra-dół

  • naciskając klawisze strzałek “Do góry” i “Na dół” na klawiaturze

  • naciskając kalwisze PgUp i PgDn na klawiaturze (przewijanie o 20 obrazków)

3.4.2 Synchronizacja serii

Serie obrazujące przekroje prostopadłe do tych samych kierunków (AXIAL, SAGGITAL, CORONAL) mogą być przeglądane wspólnie (synchronicznie) w ten sposób, aby obrazy poszczególnych serii wyświetlane jednocześnie pokazywały ten sam lub jak najbliższy region anatomiczny.

Do synchronicznego przeglądania serii służą narzędzia synchronizacji automatycznej i synchronizacji manualnej.

Synchronizację automatyczną stosuje się do synchronicznego przeglądania serii w ramach jednego badania (study). Po „wciśnięciu” przycisku synchronizacji automatycznej obrazy odpowiadających sobie kierunkiem serii przewijają się synchronicznie.

Synchronizację ręczną (manualną) stosuje się do synchronicznego przeglądania serii należących do różnych badań. Po „wciśnięciu” przycisku synchronizacji ręcznej obrazy odpowiadających sobie kierunkiem serii różnych badań przewijają się synchronicznie. Ponieważ obrazy pochodzące z różnych badań należą do różnych układów odniesienia przestrzennego, wskazanie odpowiadających sobie regionów anatomicznych musi być dokonane przez operatora. Za odpowiadające sobie obrazy uznaje się te, które są wyświetlane w momencie naciśnięcia przycisku synchronizacji ręcznej.

3.4.3 Przewijanie serii przy użyciu kursora 3D

Kolejnym sposobem przeglądania obrazów wielu serii jednego badania jest użycie kursora 3D, opisanego dokładnie w p.3.5.8

Wszystkie otwarte serie wyświetlaja obrazy położone najbliżej miejsca wskazywanego przez kursor 3D.

Kursor 3D działa tylko w ramach serii należących do jednego badania (study).

3.5 Operacje na obrazach

Obrazy lub serie obrazów otwierają się w panelu obrazów po kliknięciu odpowiadającej im pozycji w panelu badań (opis na początku rozdz. 3.3).

Operacje wykonywane są na wskazanym obrazie. Obraz wskazujemy klikając na niego dowolnym narzędziem. Wskazany obraz ma jaśniejszy kolor ramki.

3.5.1 Wywoływanie narzędzi

Naciśnięcie prawego przycisku myszy wyswietla okienko z narzędziami.

Kliknięcie lewym przyciskiem myszy na odpowiednim narzędziu – pobiera je; kształt kursora zmienia się odpowiednio do pobranego narzędzia.

Zestaw dostępnych narzędzi zależy od rodzaju wyświetlanego obrazu (np. DSA dostępne jest tylko dla obrazów typu XA).

3.5.2 Ustawianie kontrastu

Po pobraniu narzędzia kontrastu kursor zmienia kształt. Trzymajac przyciśnięty lewy przycisk myszy regulujemy parametry wyświetlanego obrazu poprzez zmianę szerokości okna (przesuwanie myszy lewo-prawo) oraz jego poziomu ( przesuwanie myszy góra-dół).

Po kliknięciu lewym przyciskiem myszy rozwija się menu do operowania predefiniowanymi ustawieniami kontrastu. Poszczególne sekcje menu zawierają:

    • automatyczne dostosowanie kontrastu

    • ustawienia użytkownika (opis dalej)

    • ustawienia zapisane w obrazie, jeśli jest ich więcej niż jedno

    • wywołanie kreatora ustawień użytkownika

    • zamknięcie menu bez żadnych działań

Okno kreatora ustawień kontrastu pokazane jest powyżej. Obrazy z poszczególnych typów urządzeń mają osobne zbiory predefiniowanych kontrastów. Nowe ustawienia można tworzyć wpisując parametry okna z klawiatury lub wczytując je z aktualnych ustawień obrazka, z którego okna zostało wywołane.

W niedalekiej przyszłości, po wprowadzeniu procedury logowania się użytkowników do rsr2, każdy użytkownik będzie miał własne predefinicje kontrastów.

3.5.3 Ustawianie powiększenia

Po pobraniu narzędzia powiększenia kursor zmienia kształt. Trzymajac przyciśnięty lewy przycisk myszy regulujemy powiększenie obrazu (przesuw do góry – powiększanie, przesuw w dół – pomniejszanie).

3.5.4 Przesuwanie obrazu

Po pobraniu Szpilki kursor zmienia kształt. Trzymajac przyciśnięty lewy przycisk myszy regulujemy przesuwamy obraz w kadrze. Narzędzie to służy także do ogólnego wskazywania (wyróżniania) obrazów.

Narzędzie to służy także jako Kursor 3D, opisany w p.3.5.8 niniejszej instrukcji.

3.5.5 Inwersja kontrastu („negatyw”)

Narzędzie to służy do zmiany wyświetlanego obrazu na jego negatyw. Ma zastosowanie głównie do obrazów czarno-białych, zwłaszcza radiologii klasycznej. Działanie tego narzędzia jest nieco inne niż pozostałych, gdyż zmiana kontrastu następuje od razu po wybraniu narzędzia, w odniesieniu do obrazu wskazanego (obwiedzionego białą ramką – poczatek niniejszego rozdziału). Po tej operacji użytkownik pozostaje z poprzednio wybranym narzędziem.

3.5.6 Obracanie obrazu

Po pobraniu narzędzia obrotów pojawia się okno narzędzi obrotów.

Z okna narzędzi obrotów wybieramy z niego narzędzie obrotu o 90 st. w lewo lub w prawo albo narzędzie odbicia lustrzanego lewo- prawo lub góra-dół. Kliknięcie wybranym narzędziem powoduje jego zastosowanie do wybranego obrazu.

3.5.7 Obsługa obrazów ruchomych

Program rozpoznaje obrazy ruchome i wyświetla w górnej części kadru narzędzie do uruchamiania sekwencji ruchomych.

Uruchamiamy klikając na trójkątny przycisk.

Zatrzymujemy klikając na kwadratowy przycisk.

Powyższe działania wykonujemy na wskazanym obrazie, wybierane przyciski zmieniają kolor na biały podczas aktywacji.

W stanie zatrzymanym sekwencję ruchomą można przeglądać na kilka sposobów:

  • - „chwytając” i przesuwając szpilką suwak powyższego narzędzia;

  • - obracając kółkiem myszy;

  • - poruszając góra-dół myszą z wciśniętym środkowym przyciskiem;

  • - klawiszami strzałek góra-dół oraz PgUp-PgDn.

W zależności od typu ruchomego obrazu działanie pozostałych narzędzi może czasami być różne od oczekiwań.

3.5.8 Kursor 3D

Kursor 3D jest przydatny przy oglądaniu kilku serii badania CT i MR. Wskazuje to samo miejsce w ciele pacjenta na wielu obrazach jednocześnie. Możliwe jest to na obrazach serii należących do jednego badania, odnoszących się to tego samego układu współrzędnych przestrzennych (frame of reference).

Kursor 3D dostępny jest po “pobraniu” z narzędziownika Szpilki. Należy kliknąć szpilką na wybrany obraz, po czym (nie naciskając żadnego przycisku myszy) nacisnąć na klawiaturze przycisk Control. Kursor zmieni kształt na krzyżyk, podobny krzyżyk pojawi się na pozostałych obrazach badania. Poruszając kursorem widzimy odpowiadające jego położeniu miejsca na pozostałych obrazach (wyświetlane przekroje zmieniaja się zgodnie z położeniem kursora 3D.

Należy zwrócić uwagę na to, że położenie kursorów na pozostałych obrazach jest przybliżone; jest obliczane jako rzut prostopadły na najbliższy przekrój. Przy dużym odstępie przekrojów (MR, starsze CT) dokładność ta jest niewielka.

3.5.9 Wyświetlenie w skali 1:1

Narzędzie to powoduje wyświetlenie obrazu w tzw. trybie “pixel to pixel”; oznacza to, że każdy piksel obrazu oryginalnego wyświetlany jest jako jeden piksel na ekranie. Ma to znaczenie w zdjęciach radiologii klasycznej, a zwłaszcza w zdjęciach mammograficznych.

3.5.10 Lupa

Narzędzie to służy do oglądania wybranego fragmentu obrazu w powiększeniu 1:1 (czyli “pixel to pixel”); jeżeli cały obraz jest już powiększony, powiększenie lupy wynosi 3:1.

3.5.11 DSA

Narzędzie to służy do odejmowania tła w sekwencjach obrazów, zwłaszcza w badaniach naczyniowych. Dzięki temu rysunek naczyń wypełnionych kontrastem jest bardziej czytelny.

Kliknięcie przycisku DSA powoduje odjęcie trzeciej klatki sekwencji od pozostałych klatek (trzecia klatka traktowana jest jako tło). Jako tło mozna tez wybrać dowolną klatkę sekwencji wyświetlając ją i naciskając klawisz D na klawiaturze. Sekwencję z zastosowanym DSA można oglądać jak każdy obraz, stosując wszelkie dostępne narzędzia.

Należy unikać wielokrotnego aplikowania operacji DSA na tej samej sekwencji bez przywracania ustawiń początkowych przyciskiem “Reset”

3.6 POMIARY

Używając narzędzi pomiarowych należy zawsze być świadomym, że wyniki pomiarów są przybliżone. Należy zawsze zachować najwyższą ostrożność, zwłaszcza w odniesieniu do obrazów z nowych urządzeń (np. dostarczonych z zewnątrz na płycie CD). Nie jest możliwe przetestowanie wszystkich możliwych sytuacji.

Niniejsza wersja programu nie umożliwia zapisania wykonanych pomiarów.

3.6.1 Zasady używania narzędzi pomiarowych

Narzędzia pomiarowe pobieramy z tego samego okna, co narzędzia do operacji na obrazach (p.3.4.1).

Pomiary – linie i wyniki – są jedynie wyświetlane na ekranie i w żaden sposób nie powodują zmiany treści obrazu oryginalnego.

Pomiar składa się z linii pomiarowych wyznaczonych węzłami oraz z opisu pomiaru.

Istniejący pomiar można edytować - zmienić położenie węzłów i linii, zmienić położenie opisu oraz usunąć cały pomiar.

Operacje na istniejących pomiarach można wykonać mając aktywne dowolne narzędzie. Wystarczy najechać kursorem na linię, węzeł lub opis (kursor zmienia kształt gdy jest gotowy do operacji nad pomiarem), nacisnąć lewy przycisk myszy i przesunąć wybrany element w nowe miejsce.

Jeżeli zamiast lewego przycisku myszy naciśniemy prawy, to otworzy się okno narzędzi zawierające m.in. kosz; po jego wybraniu pomiar zostaje usunięty.

Należy zaznaczyć, że w przypadku obrazów ruchomych zalecane jest zatrzymanie sekwencji przed wykonywaniem lub edycją pomiarów.

3.6.2 Pomiar odległości

Pomiar odległości na obrazie nie zawierającym informacji o wielkości piksela i nie skalibrowanym daje wynik ZERO.

Do wykonywania pomiarów używamy narzędzia pokazanego obok. Aby zmierzyć odległość pomiędzy dwoma punktami należy kliknąć lewym przyciskiem myszy na pierwszy punkt i trzymajac wciśnięty lewy przycisk myszy wskazać drugi punkt, po czym zwolnić lewy przycisk myszy. Położenie końców mierzonego odcinka możemy łatwo skorygować w sposób opisany w p.3.6.1 .

3.6.3 Kalibracja pomiaru odległości

Obrazy z niektórych urządzeń nie mają zapisanej informacji o wielkości piksela. Na obrazach takich nie jest możliwy pomiar odległości ani żadnych innych wielkości geometrycznych. Sytuacja taka występuje np. w przypadku obrazów z prostych urządzeń radiologii klasycznej i ultrasonografii. W przypadku cyfrowych zdjęć radiologii klasycznej (z aparatów cyfrowych DR lub z systemów ucyfrowionych CR) obrazy mają co prawda informację o wielkości piksela, jednakże ze względu na występujące na nich różne powiększenie geometryczne organów leżących w różnych miejscach ciała pacjenta dokładny pomiar odległości na podstawie wielkości piksela również nie jest mozliwy.

Kalibracja obrazu polega na wskazaniu na obrazie elementu o znanej wielkości (np. fragmentu endoprotezy, średnicy cewnika, elementu przymocowanego w odpowiednim miejscu do ciała pacjenta – kulka, literka, znacznik) i podanie jego rzeczywistej wielkości.

Po tej operacji wielkość piksela zostanie odpowiednio przeliczona i zmieniona do czasu wykonania następnej kalibracji lub zamknięcia obrazu. Odpowiedniemu przeliczeniu ulegną wszystkie zaznaczone dotychczas na obrazie pomiary.

UWAGA! Pomiary związane z obszarem zaznaczonym krzywą spline nie są aktualizowane do czasu wykonania jakiejkolwiek operacji na tej krzywej. Zostanie to poprawione w kolejnej wersji programu.

Należy zachować najdalej idącą ostrożność i staranność przy stosowaniu zabiegu kalibracji obrazu.

Aby wykonać kalibrację obrazu należy zmierzyć element o znanej wielkości po czym „wskazać” go kursorem i nacisnąć klawisz „k”. (Najwygodniejsze jest wskazanie tekstu oznaczającego odległość – kursor zmienia się wówczas w znak litery T otoczonej kwadratem.)

Pojawia się okienko z polem, w które należy wpisać właściwą – znaną – długość elementu mierzonego. Po potwierdzeniu przyciskiem „Ustaw” wszystkie odległości na obrazie zostaną przekalibrowane (p. uwaga powyżej!)

3.6.4 Pomiar kąta

Pomiar kąta na obrazie nieskalibrowanym może być obarczony błędem, gdyż skale odległości w kierunku pionowym i poziomym mogą być różne. Jest to obecnie rzadko spotykane, dlatego pomiar kąta został na nieskalibrowanym obrazie został dopuszczony – w większości przypadków jest on prawidłowy. Jeżeli pomiary wykonywane są na obrazie nieznanego typu należy zawsze upewnić się, czy skale o których mowa są jednakowe, a najlepiej skalibrować obraz.

Do wykonywania pomiarów używamy narzędzia pokazanego obok. Aby zmierzyć kąt należy kliknąć lewym przyciskiem myszy w okolicy wierzchołka mierzonego kąta i trzymajac wciśnięty lewy przycisk myszy wskazać drugi punkt, po czym zwolnić lewy przycisk myszy. Teraz, sposobem opisanym w p.3.5.1. ustawiamy położenie wszystkich elementów kąta.

Należy zwrócic uwagę na to, że oprócz węzłów w wierzchołku kąta i na końcach jego ramion, istnieją węzły pośrodku kamion kąta. Umożliwiają one nietypowe operowanie kątem – na przykład skonstruowanie kąta bez wierzchołka lub kąta w konfiguracji „T”.

3.6.5 Pomiar obszaru zaznaczonego okręgiem

Pomiar obszaru zaznaczonego okręgiem pozwala narysować okrąg, umieścić go w dowolnym miejscu obrazu i zmierzyć jego pole. Narzędzie to traktowane jest jako narzędzie pomocnicze. Do zaznaczania obszarów o dowolnym kształcie służy narzędzie omówione w p.3.5.6.

Do rysowania okręgu służy narzędzie pokazane obok. Aby narysować okrąg należy kliknąć lewym przyciskiem myszy w miejsce środka rysowanego okręgu i trzymając wciśnięty przycisk myszy przesuwać ją do uzyskania żądanej wielkości okręgu. Węzły pozwalające zmieniać wielkość okręgu znajdują się na obu końcach promienia. Okrąg można przesunąć „chwytając” za jego promień.

3.6.6 Pomiar obszaru zaznaczonego krzywą Beziera

Narzędzie to służy do zaznaczania obszarów o prostych lub skomplikowanych kształtach i obliczania jego pola powierzchni oraz średniej gęstości. Pod określeniem „gęstość” kryje się gęstość w skali Hounsfielda w przypadku obrazów z tomografii komputerowej; w przypadku innych obrazów mogą to być parametry interpretowane różnie, w zależności od typu obrazu.

Do zaznaczania obszaru krzywą Beziera (zwaną również „spline”) służy narzędzie pokazane obok. Rysuje ono krzywą zamkniętą. Aby narysować krzywą Beziera należy klikać lewym przyciskiem myszy w kolejne miejsca leżące na obwodzie zaznaczanego obszaru. Ostatni punkt krzywej klikamy prawym przyciskiem myszy. Wynik pomiaru wyświetlany jest po zakończeniu rysowania krzywej.

Podobnie jak w przypadku innych pomiarów, otrzymaną krzywą Beziera można edytować przesuwając poszczególne węzły lub całą krzywą. Nie jest możliwe dodawanie ani usuwanie węzłów raz narysowanej krzywej. Krzywą można usunąć tak, jak każdy pomiar, sposobem opisanym w p.3.5.1.

UWAGA! Pomiary związane z obszarem zaznaczonym krzywą spline nie są aktualizowane do czasu wykonania jakiejkolwiek operacji na tej krzywej. Zostanie to poprawione w kolejnej wersji programu.

3.7 NAGRYWANIE BADAŃ NA PŁYTY CD/DVD

Nagrywanie badań na płyty dostępne jest z okna archiwum podręcznego.

Są trzy tryby nagrywania:

  • bezpośrednio z panelu badań

  • bezpośrednio z okna archiwum podręcznego

  • za pośrednictwem bufora nagrywania

Aby nagrać badanie bezpośrednio z panelu badan należy kliknąć prawym przyciskiem myszy na jego nagłówek (czarny prostokąt z nazwiskiem pacjenta) I wybrać “Nagraj badanie na nośnik optyczny”. W ten sposób można nagrać tylko jedno badanie. Sposób ten umożliwia nagranie na płytę badania bez jego zapisywania do archiwum lokalnego.

Aby nagrać badania z okna archiwum podręcznego należy na liście badań zaznaczyć te, które mają zostać nagrane na płytę i kliknąć przycisk “Nagraj zaznaczone na nośnik optyczny”. Ten sposób jest odpowiedni do nagrywania jednego lub kilku badań.

Przy nagrywaniu większej ilości badań wygodniej jest skorzystać z bufora nagrywania, do którego badania dodawane są po każdym kliknięciu przycisku “Dodaj zaznaczone do bufora nagrywania”.

Okno bufora nagrywania można wywołać w każdej chwili przyciskiem

Okno bufora nagrywania pokazane jest poniżej:

Na dole okna można odczytać ilość danych przeznaczonych do zapisania na płytę.

Przebieg procesu nagrywania...

Po kliknęciu przycisku “Nagraj zaznaczone na nośnik optyczny” w oknie archiwum podręcznego lub przycisku “Nagraj płytę” w oknie bufora nagrywania uruchamia się program nagrywający Burn.exe. Zgodnie z instrukcjami należy włożyć odpowiedni nośnik (CD lub DVD dowolnego typu) do napędu optycznego.

Po zakończeniu nagrania napęd otwiera się, pojawia się także odpowiedni komunikat na ekranie.

Przy nagrywaniu większej ilości danych proces nagrywania może trwać nawet kilkadziesiąt minut. Nagrana płyta zawiera obrazy wybranych do nagrania badań, przeglądarkę RSR2Lite oraz plik DICOMDIR umieszczony w katalogu głównym.

3.8 USUWANIE BADAŃ Z ARCHIWUM PODRĘCZNEGO

Aby usunąć badanie z archiwum podręcznego należy zaznaczyć je na liście i kliknąć przycisk „Usuń zaznaczone badanie z archiwum”. Można usuwać jedynie całe badania.

3.9 WYSYŁANIE BADAŃ DO SERWERÓW PACS

Aby wysłać badanie do serwera PACS należy je zaznaczyć na liście badań w archiwum lokalnym (p.3.3.2 ) i kliknąć przycisk “Wyślij zaznaczone poprzez Dicom”. Pojawi się wówczas okno z listą skonfigurowanych serwerów PACS z której trzeba wybrać ten, do którego chcemy wysłać badanie.

Po kliknięciu przycisku “Wyślij” pojawia się pasek postępu i obrazy sa wysyłane. Należy zwrócić uwagę na to, że na powyższa lista jest taka sama jak lista serwerów w oknie Query/Retrieve (opis w p.3.3.3 ); może się zdarzyć, że nie wszystkie pozycje na liście będą serwerami Store SCP (a tylko do nich można wysłać obrazy), w takim przypadku pojawi się okno z komunikatem błędu, np. „Brak akceptowalnych Presentation Contexts”.

3.10 NARZĘDZIA DODATKOWE

3.10.1 Przeglądarka tagów

Po wybraniu obrazka (wybrana seria zaznaczona jest w panelu badań zieloną kropką) I wybraniu z menu górnego Narzędzia-> Przeglądanie tagów obrazu – otwiera się okno przeglądarki tagów.

W jej oknie wyświetlana jest lista wszystkich niezerowych tagów dicom odczytanych z nagłówka wybranego obrazu. Listę wyświetlana jest według numerów tagów. Listę można przeszukiwać po numerze tagu lub po początku nazwy tagu.

Można otworzyć więcej niż jedno okno przeglądarki tagów – każde dla innego obrazu.

4 KONFIGUROWANIE PROGRAMU

Konfigurowanie aplikacji RSR2 odbywa się narzędziem dostępnym z

Menu>Konfiguracja>Konfiguracja RSR2

Konfigurowanie napisów (overlays) na obrazach z różnych modalities odbywa się narzędziem dostępnym z

Menu>Konfiguracja>Konfiguracja adnotacji na obrazach

Konfigurowanie wyszukiwarki Dicom Query/Retrieve oraz serwerów do których będą wysyłane obrazy odbywa się narzędziem dostępnym z

Menu>Konfiguracja>Konfiguracja urządzeń zewnętrznych.

4.1 Konfigurowanie serwisowe

4.1.1 Struktura katalogów

Aplikacja RSR2 instalowana jest domyślnie w katalogu C:\Program Files\RSR2 i katalog ten okreslamy jako katalog bazowy.

W katalogu bazowym jest pięć podkatalogów:

  • Archive – są w nim zapisywane pliki obrazowe zaimportowane do archiwum podręcznego lub przysłane z sieci PACS poprzez Dicom Store;

  • CD – zawiera elementy stałe zapisywane na płycie pacjenta i katalog roboczy zapisu;

  • DB – zawiera pliki baz danych;

  • Snippets - „snippety” - do przyszłego użytku;

  • TOOLS – zawiera aplikacje zewnętrzne współpracujące z RSR2; do przyszłego użytku;

  • można utworzyć katalog logs w którym zapisywane byłyby logi gdyby zostały włączone; domyślnie logi są wyłączone;

Konfiguracja katalogów (jeśli użytkownich chce zmienić konfigurację domyślną) dostępna jest poprzez

Menu>Konfiguracja>Konfiguracja RSR2, w zakładce „Katalogi”.

4.1.2 Konfigurowanie współpracy z siecią PACS

Współpraca z siecią PACS polega na:

  • odbieraniu obrazów wysyłanych przez inne urządzenia – realizuje to serwis Dicom Store SCP;

  • wysyłaniu zapytań (Query) o badania danego pacjenta – realizuje to serwis Dicom Query SCU;

  • wysyłaniu obrazów do iinnych serwerów PACS - – realizuje to serwis Dicom Store SCU;

Konfiguracja serwisu Dicom Store SCP polega na nadaniu programowi AE_Title I ustaleniu na którym porcie będzie odbierał obrazy. Dokonuje się tego w zakładce DICOM_STORE okna Ustawienia, które otwiera się poprzez:

Menu->Konfiguracja->KonfiguracjaRSR2

Po zmianie tych parametrów należy zrestartować program.

UWAGA! Przykłady konfigurowania najczęściej spotykanych serwerów PACS będą opisywane na stronie rsr2.pl

Konfiguracja serwerów PACS pełniących role Query/Retrieve SCP i Store SCP dokonywana jest narzędziem dostępnym z:

Menu>Konfiguracja>Konfiguracja urządzeń zewnętrznych

Jest to okno „Konfiguracja urządzeń” w które należy wpisać kolejne serwery podając ich nazwy potoczne (najlepiej określające ich lokalizację – np. „Chirurgia Naczyniowa II p.”) i parametry sieciowe PACS: AE_Title, adres IP i numer portu.

Przycisk „Weryfikacja” umożliwia wstępne sprawdzenie, czy wybrany serwer odpowiada na zapytanie wysłane w standardzie Dicom.

4.2 Konfigurowanie adnotacji na obrazach

Po wybraniu Menu>Konfiguracja>Konfiguracja adnotacji na obrazach ukazuje się okno ustawień.

Ustawien dokonujemy dla modality wybranego z rozwijalnej listy.

W części środkowej znajduje się lista wszystkich tagów.

Cztery obszary po bokach symbolizują poszczególne narożniki obrazu. Wybrany tag przeciągamy i upuszczamy w rogu, w którym ma się wyświetlać.

Po skompletowaniu napisów należy kliknąć przycisk „Zapisz”.

4.3 Konfigurowanie innych urządzeń w sieci PACS

Serwery z których RSR2 będzie pobierał obrazy muszą mieć wpisane jego dane do swojej konfiguracji. Powinna to wykonać osoba odpowiedzialna za sieć obrazową lub serwis producenta.

UWAGA! Przykłady konfigurowania najczęściej spotykanych serwerów PACS będą opisywane na stronie rsr2.pl

4.4 Konfigurowanie Windows

Prawidłowe działanie niektórych programu zależne jest od odpowiedniej konfiguracji systemu operacyjnego Windows.

4.4.1 Nagrywanie badań na płyty CD/DVD przez „zwykłego” użytkownika

W Windows XP Prof użytkownik z ograniczonymi uprawnieniami nie może nagrywać danych na płyty CD/DVD. Aby to zmienić należy z linii poleceń uruchomic program gpedit.msc, w lewym panelu znaleźć:

Konfiguracja komputera->Ustawienia systemu Windows->Ustawienia zabezpieczeń->Zasady lokalne->Opcje zabezpieczeń
i ustawić parametr

"Urządzenia: ogranicz dostęp do stacji CD-ROM tylko do użytkownika zalogowanego lokalnie" na "Włączony"
Dokładny opis na stronie firmy Microsoft. Poniżej zrzut odpowiedniego ekranu z polskich Windows:

5 WYMAGANIA SPRZĘTOWE

Program RSR2 może być instalowany na komputerach klasy PC pod systemem operacyjnym Windows XP Professional SP3.

Zalecana ilość pamięci RAM to conajmniej 1 GB, chociaż program pracować może również przy mniejszej ilości pamięci.

Zbyt mała ilość pamięci spowoduje wolniejszę pracę programu.

Komputer powinien być wyposażony w kolorowy monitor o wielkości 19”.

6 SERWIS I POSTĘPOWANIE W SYTUACJACH AWARYJNYCH

Producentem programu jest firma:

IM s.c. Adam Bielicki, Cezariusz Ścisiński

ul.Falińskiego 6, 05-080 Truskaw

tel/fax (022) 721 8666

Osobami odpowiedzialnymi za program RSR2 są:

Adam Bielicki abielicki@archimedic.pl

Bartosz Wiklak bwiklak@archimedic.pl

Wszelkie pytania i uwagi należy kierować do powyższych osób.

Wszelkie przypadki nieprawidłowego działania programu, a zwłaszcza nieprawidłowe wyświetlanie obrazów lub nieprawidłowe wyniki pomiarów należy jak najszybciej zgłaszać do producenta.

Należy mieć na uwadze, że nie jest możliwe przetestowanie zachowania się programu we wszystkich możliwych przypadkach, zwłaszcza podczas pracy z coraz to nowymi typami obrazów.

Należy również mieć świadomość, że producent musi mieć możliwość zawiadomienia użytkowników programu o ewentualnych wykrytych błędach i nieprawidłowościach w jego działaniu. Dlatego rejestrując się użytkownik powinien podać swój aktualny, używany adres email. Z polityką prywatności można zapoznać się na stronie rsr2.pl.

RSR2 IO v3.5 20090508 28